各XSI / Softimage/Face Robot 用戶可在這裡交流問題和分享制作經驗

版主: HapZungLam


文章hahasum » 14日 7月 2010年, 13:01

我想問問,點先可以系xsi render float Z﹣depth,因為maya會收系Z既channel,但xsi好似無,希望有高人幫幫手,thx
文章: 14
註冊時間: 26日 4月 2008年, 11:51

Share On:

Share on Facebook Facebook Share on Twitter Twitter

文章HapZungLam » 15日 7月 2010年, 14:17

There has a multiple ways to achieve that.

You can either simply add a depth framebuffer to your current pass. Or to have more control you may add a depth volume pass shader on your pass.

1. Depth framebuffer

In your upper left hand corner of your render region has a triangle. click that and choose -> render channel -> depth

It'll render only the z-depth as your render and you can save it off to whatever format you want as you save off from any of your render region.

However, if you want to render it as a regular render(non render region). You may:

prees 3 to your render tab -> pass-> edit-> edit current pass

now the passes property page has pop up and you can go under Output tab - > Render Channels Output -> click Add.... and a "create framebuffer from render channel" window has popup and in the drop down menu you may choose "depth" and click OK.

There will be a new framebuffer added under your "render channels output" select the new framebuffer that you have just added and hit edit. And now you can choose the output format there. Default is already in .zt file, channel as Depth and its an Float image (I don't usually work with depth pass by all means i have no idea what are those)

And now you can just click off render current pass and it should give you 2 images, 1 as your main render and the other is the .zt float file.

2. Depth pass

If you need more control on your depth. eg: you may set different partition to different groups of object to have different depth result. Or you may want to control the depth value. Then all you need to do is to create a seperated pass.

prees 3 to your render tab -> pass -> edit-> new pass -> depth

now be careful that since you've created a new pass. Everything inside this pass will now just follow as your depth settings. It doesn't have anything/any settings to do with your default pass. And now if you do either render region or a regular render, it'll give you depth. To adjust your depth value. Go to pass -> edit -> edit current pass-> go to "pass shaders" tab. You'll realize that there has a "depth_volume" shader has been added to your volume. Double click on that to get into the depth_volume property page. And have fun with it.

Since it is a depth "pass" there will no need to add any depth framebuffer anymore. Cuz your main framebuffer will already have the depth_volume shader to control it. However, you may not change the file format to .zt anymore. Cuz main framebuffer is not allow to use .zt format for some stupid reason.

I hope I've explain clear enough. I know its a bit confusing as for maya user. Plz feel free to ask if you get stuck. Good luck and hope it helps.
文章: 1143
註冊時間: 30日 8月 2001年, 08:00
來自: Vancouver

回到 Autodesk Softimage


正在瀏覽這個版面的使用者:沒有註冊會員 和 2 位訪客